mandrivabrasil.org - Forum
17 de Abril de 2014, 04:41 *
Bem-vindo, Visitante. Por favor faça o Login ou Registro.

Login com nome de usuário, senha e duração da sessão
Notícias: ATENÇÃO: Caso não estejam conseguindo postar mensagens e tópicos no forum, com mensagem de erro "sessão expirada", removam TODOS os cookies do navegador com o domínio mandrivabrasil e depois loguem-se novamente no forum.
 
   Home   Ajuda Login Registrar  
Páginas: [1]   Ir para o Fundo
  Imprimir  
Autor Tópico: D-LINK Wireless ADSL+Router  (Lida 4460 vezes)
carlo.costa
Membro Intermediário
***
Offline Offline

Mensagens: 101


Ver Perfil
« : 15 de Julho de 2007, 22:18 »

Tenho o Mandriva 2007 PackPlus instalado junto com o XP num notebook Lenovo ThinkPad T60. A conexão é via Velox de 2Mb.
O kernel instalado é o 2.6.17-5mdv.
Comprei e estou tentando  usar um router wireless da D-LINK mod. DSL 2640T
O router com cabo funciona sem nenhum problema tanto no Mandriva como no XP, mas não consigo instalar o wireless no Mandriva, enquanto que no XP funciona muito bem.
Quando tento instalar a rede wireless através do CCM, me diz para usar o nsdiswrapper, mas  depois diz que não encontrou nenhum driver.
Tentei instalar uma versão mais recente (1.47) mas não consegui.
No site da NDsiwrapper não encontrei este hardware na lista dos suportados, mas nem encontro nenhum DSL 2640T.
Estou fazendo algo errado ou ele não é mesmo suportado?
Registrado
Manoel Pinho
Administrador
Membro Vitalício
*****
Offline Offline

Mensagens: 8.415


inVISTA no seu conhecimento aprendendo linux !


Ver Perfil WWW
« Responder #1 : 17 de Julho de 2007, 13:54 »

O router não tem nada a ver com o fato de não estar conseguindo acessar no linux. O problema com certeza é na configuração da placa wireless no seu micro. Antes de tudo você precisa dizer o modelo dela. Veja com o comando lspci (como root).

Ndiswrapper é usado só quando não existe um driver nativo e por isso é preciso saber antes que placa vc tem.
Registrado

carlo.costa
Membro Intermediário
***
Offline Offline

Mensagens: 101


Ver Perfil
« Responder #2 : 19 de Julho de 2007, 08:56 »

Obrigado, Pinho.

A placa wireless é uma Atheros, veja abaixo:
.....
02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controller
03:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
15:00.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
[root@localhost Custos]#
Registrado
Manoel Pinho
Administrador
Membro Vitalício
*****
Offline Offline

Mensagens: 8.415


inVISTA no seu conhecimento aprendendo linux !


Ver Perfil WWW
« Responder #3 : 19 de Julho de 2007, 22:05 »

Use o madwifi

http://www.mandrivabrasil.org/site/forum/index.php?topic=2553.0

http://www.mandrivabrasil.org/site/forum/index.php?topic=2539.0

http://www.vivaolinux.com.br/dicas/verDica.php?codigo=6870
(o Fedora é bem semelhante ao mandriva nos procedimentos de configuração, mas logicamente não é para usar os pacotes do fedora)
Registrado

carlo.costa
Membro Intermediário
***
Offline Offline

Mensagens: 101


Ver Perfil
« Responder #4 : 21 de Julho de 2007, 19:03 »

Voltei, Pino, e fui buscar o madwifi, depois de atualizar o kerel-source para a minha versão do kernel.
Baixei o madwifi-0.9.3.1, descompactei em /opt, instalei com make e make install, seguindo as instruções do MadWifi `First Time User ` HOW TO que você sugeriu, e parece que tudo correu bem porque não mhouve mensagem de erro me a saida do modprobe ath_pci está correta.

root@localhost carlo]# modprobe ath_pci
[root@localhost carlo]# echo $?
0

No entanto a saida do iwconfig não encontra a placa Atheros.
[root@localhost carlo]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

e depois

[root@localhost carlo]# wlanconfig ath0 create wlandev wifi0 wlanmode sta
wlanconfig: ioctl: No such device
[root@localhost carlo]#     

e também


[root@localhost carlo]# modprobe wlan_scan_sta
[root@localhost carlo]# wlanconfig ath0 list scan
ioctl[unknown???]: No such device
wlanconfig: unable to get scan results
[root@localhost carlo]#                                       

O que aconteceu e como conserto?

sit0      no wireless extensions.

[root@localhost carlo]#
Registrado
Manoel Pinho
Administrador
Membro Vitalício
*****
Offline Offline

Mensagens: 8.415


inVISTA no seu conhecimento aprendendo linux !


Ver Perfil WWW
« Responder #5 : 21 de Julho de 2007, 20:21 »

Você fez o passo

wlanconfig ath0 create wlandev wifi0 wlanmode sta

para criar a interface ath0 como está no howto ?
Registrado

carlo.costa
Membro Intermediário
***
Offline Offline

Mensagens: 101


Ver Perfil
« Responder #6 : 22 de Julho de 2007, 18:35 »

Fiz como manda no How To, mas não sei o que seja o "svn snapshot".
O que eu quero é ter  um acesso wireless para o Velox usnado o D-Link DSL 2640T, que é perfeitamente suportado pelo madwifi.

Depois disto ainda fui procurar a existência de um ponto de acesso ( que existe e funciona), como diz o How To, mas tive a seguinte reposta:

[root@localhost carlo]# modprobe wlan_scan_sta
[root@localhost carlo]# echo $?
0
[root@localhost carlo]# wlanconfig ath0 list scan
ioctl[unknown???]: No such device
wlanconfig: unable to get scan results
[root@localhost carlo]# iwlist ath0 scan
ath0      Interface doesn't support scanning.

[root@localhost carlo]#

Aí fui verificar se o módulo ath0 está instalado, e ele não está:

[root@localhost carlo]# lsmod |grep ath0
[root@localhost carlo]#

Onde errei?
 
Registrado
Manoel Pinho
Administrador
Membro Vitalício
*****
Offline Offline

Mensagens: 8.415


inVISTA no seu conhecimento aprendendo linux !


Ver Perfil WWW
« Responder #7 : 22 de Julho de 2007, 21:11 »

Você reparou a msg de erro ?

# wlanconfig ath0 list scan
ioctl[unknown???]: No such device

O device ath0 não foi criado e por isso fiz a pergunta anterior a vc. Alguma coisa você não fez ou a compilação do módulo deu erro e vc não reparou. Dá uma lida na documentação

http://madwifi.org/wiki/UserDocs

e veja se não aparece alguma msg de erro durante a compilação.
Registrado

carlo.costa
Membro Intermediário
***
Offline Offline

Mensagens: 101


Ver Perfil
« Responder #8 : 25 de Julho de 2007, 20:53 »

Refiz tudo, Pinho e agora consegui instalar

[root@localhost madwifi]# lsmod |grep ath_pci
ath_pci               106120  0
wlan                  200944  4 wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal               231712  3 ath_rate_sample,ath_pci
[root@localhost madwifi]# ifconfig ath0 up
[root@localhost madwifi]# ifconfig wifi up
wifi: interface desconhecida: Dispositivo inexistente
[root@localhost madwifi]# iwlist ath0 scan
ath0      Scan completed :
          Cell 01 - Address: 00:1B:11:39:97:E8
                    ESSID:"CCOSTA"
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Quality=67/70  Signal level=-28 dBm  Noise level=-95 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                              6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:bcn_int=200
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                       Preauthentication Supported

mas não consigo me conectar e navegar:

[root@localhost madwifi]# iwconfig ath0 essid "CCOSTA"
[root@localhost madwifi]# dhclient ath0
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
/sbin/dhclient-script: configuration for ath0 not found.
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:19:7d:13:25:f2
Sending on   LPF/ath0/00:19:7d:13:25:f2
Sending on   Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 14
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
/sbin/dhclient-script: configuration for ath0 not found.
[root@localhost madwifi]#       

Registrado
carlo.costa
Membro Intermediário
***
Offline Offline

Mensagens: 101


Ver Perfil
« Responder #9 : 28 de Julho de 2007, 10:48 »

Bom dia, Pinho

Apesar de tudo instalado corretamente

[root@localhost carlo]# wlanconfig ath0 list scan
SSID            BSSID              CHAN RATE  S:N   INT CAPS
CCOSTA          00:1b:11:39:97:e8    6   54M 53:0   200 EPSB RSN
[root@localhost carlo]#

e dmesmo tendo dado o comando    ifconfig  wifi up
quando vou para o MCC e tento configurar a rede, não consigo a conexão wireless.

Configurei como:
Conexão - wireles
Interface - Atheros Communications Inc. - AR5212 802.11abg NIC
Selecionei a rede como - CCOSTA
Modo de operação - Gerenciado
Modo de criptografia - Chave WPA pré-compartilhada
IP Automático (BOOT/DHCP)
Obter servidor DNS do DHCP
Obter o nome da máquina a partir do endereço DHCP
Iniciar a conexão no boot
Permitir ponto de acesso remoto.

Digo que sim quando me pergunta se quero iniciar a conexão agora, mas a rede continua sem conexão.
Poucos segundos depois me dá os parabens e me manda reiniciar o servidor X para não perder o nome.

Verifiquei, porém, que na opção de menu do MCC "Conexão wireless" tenho  os seguintes parâmetros como sendo a minbha configuração:

SSID - CCOSTA
Sinal - ícone verde
Criptografia -  WPA ( com ícone de cadeado fechado)
Modo de operação - Master

O modo de operação não deveria estar como "Gerenciado" ?
Tentei muda-lo através da opção Configurar, mas não adianta porque não muda na janela principal.

Como devo fazer?
Registrado
carlo.costa
Membro Intermediário
***
Offline Offline

Mensagens: 101


Ver Perfil
« Responder #10 : 14 de Agosto de 2007, 14:08 »

Com a ajuda do Suporte do Mandriva consegui resolver o problema e aqui passo a solução sugerida, que funcionou, para eventuais problemas semelhantes que outros venham a encontrar.

"você está provavelmente usando um ponto de acesso wireless com criptografia com chave WEP. Para isso, abra o Centro de Controle Mandriva, Rede & Internet, e Conexão Wireless. Selecione a rede que deseja conectar-se (note o símbolo de cadeado e a inscrição [WEP] em criptografia. Selecione "Configurar". Em "Chave criptográfica" digite a senha de acesso a rede wireless (entre em contato com seu administrador local de
rede para obter a senha da rede wireless).'

Como eu tinha a senha, ficou fácil.

De qualquer forma agradeço ao Pinho pelaq ajuda.
Registrado
adhefe
Membro Vitalício
*****
Offline Offline

Mensagens: 906


Ver Perfil
« Responder #11 : 27 de Dezembro de 2007, 22:24 »

Caro Carlo.Costa,

Gostaria de saber se você conseguiu configurar para criptografia mais forte (WPA2?). Estou pensando em instalar uma rede sem fio por aqui e já me avisaram que terei problemas para fazê-lo com WPA2 em Línux 64 bits. Você confirma?

Aqui, Mandriva 2008.0, 64 bits. Uso Vélox.

Obrigado.
Registrado
Páginas: [1]   Ir para o Topo
  Imprimir  
 
Ir para:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines XHTML 1.0 Válido! CSS Válido!