mandrivabrasil.org - Forum
23 de Abril de 2014, 11:42 *
Bem-vindo, Visitante. Por favor faça o Login ou Registro.

Login com nome de usuário, senha e duração da sessão
Notícias: ATENÇÃO: Caso não estejam conseguindo postar mensagens e tópicos no forum, com mensagem de erro "sessão expirada", removam TODOS os cookies do navegador com o domínio mandrivabrasil e depois loguem-se novamente no forum.
 
   Home   Ajuda Login Registrar  
Páginas: [1]   Ir para o Fundo
  Imprimir  
Autor Tópico: Instalar driver do leitor de cartões.  (Lida 16372 vezes)
Peter Parker
Moderador Global
Membro Vitalício
*****
Offline Offline

Mensagens: 2.367



Ver Perfil WWW
« : 12 de Fevereiro de 2009, 19:12 »

Pessoal,
Preciso instalar esses drivers e já tenho o procedimento, mas não consigo fazer de forma alguma.

O Procedimento é esse:

  Standalone kernel module

In order to create the driver module (kernel headers have to be installed) you can use this archive. It contains the One driver out of the kernel package, patched by Christian Rothländer, and a patched Makefile which works without the kernel sources. In other words, you won't have to (re-)build a full kernel, only the module itself.

$ wget http://www.a110wiki.de/wiki/images/0/06/Cardreader2.tar.bz2
$ tar xfvj Cardreader2.tar.bz2
$ cd via2
$ make

This archive doesn't seem to build for 2.6.25 out of the box, but it will likely work for 2.6.24.

After building, you can load the module respective *.ko files via insmod.

O erro que dá é esse:

[root@localhost via2]# make
make -C /lib/modules/`uname -r`/build M=`pwd` modules
make[1]: Entrando no diretório `/lib/modules/2.6.27.10-desktop586-1mnb/build'
make[1]: *** Sem regra para processar o alvo `modules'.  Pare.
make[1]: Saindo do diretório `/lib/modules/2.6.27.10-desktop586-1mnb/build'
make: ** [default] Erro 2


To no MDV 2009.0 xfce no Positivo Mobo

Registrado

Acessem meu blog - http://diogoparker.wordpress.com/
Follow me on Twitter - http://twitter.com/Diogo_Travassos
Mandriva BR no Twitter - http://twitter.com/mandriva_br
atf
Visitante
« Responder #1 : 13 de Fevereiro de 2009, 11:45 »

Aparentemente é uma impropriedade no "makefile" que parece testar exclusivamente para a versão 2.6.24.
Que mal pergunte: que leitor é esse que precisa de um "driver"?
Registrado
Peter Parker
Moderador Global
Membro Vitalício
*****
Offline Offline

Mensagens: 2.367



Ver Perfil WWW
« Responder #2 : 13 de Fevereiro de 2009, 21:39 »

Aparentemente é uma impropriedade no "makefile" que parece testar exclusivamente para a versão 2.6.24.
Que mal pergunte: que leitor é esse que precisa de um "driver"?

É, esse driver não funciona no kernel novo, já rodei por aí...

O leitor é do Positivo Mobo, ele precisa de driver mesmo, ele conversa direto com o barramento pci, por isso é mais complicado. Se fosse USB seria ótimo, não sei por que complicam as coisas.
Registrado

Acessem meu blog - http://diogoparker.wordpress.com/
Follow me on Twitter - http://twitter.com/Diogo_Travassos
Mandriva BR no Twitter - http://twitter.com/mandriva_br
atf
Visitante
« Responder #3 : 14 de Fevereiro de 2009, 16:00 »

Tenta alterar no "makefile". Lá deve ter algo como: ...=...2.6.24. Altere para ...=>...2.6.24. Assim não fica limitado a uma única versão de "kernel".
Registrado
Manoel Pinho
Administrador
Membro Vitalício
*****
Offline Offline

Mensagens: 8.415


inVISTA no seu conhecimento aprendendo linux !


Ver Perfil WWW
« Responder #4 : 15 de Fevereiro de 2009, 16:13 »

Bem chato isso mesmo...

Só para ficar registrado aqui para quem tiver problema semelhante, as instruções para usar linux neste equipamento estão em

http://www.a110wiki.de/wiki/Main_Page
Registrado

Peter Parker
Moderador Global
Membro Vitalício
*****
Offline Offline

Mensagens: 2.367



Ver Perfil WWW
« Responder #5 : 16 de Fevereiro de 2009, 18:10 »

Bem chato isso mesmo...

Só para ficar registrado aqui para quem tiver problema semelhante, as instruções para usar linux neste equipamento estão em

http://www.a110wiki.de/wiki/Main_Page
Pois é, só fizeram fuuncionar tudo no Ubuntu, inclusive desenvolveram uma remaster com o ubuntu com todos os drivers pré-instalados.
Registrado

Acessem meu blog - http://diogoparker.wordpress.com/
Follow me on Twitter - http://twitter.com/Diogo_Travassos
Mandriva BR no Twitter - http://twitter.com/mandriva_br
Páginas: [1]   Ir para o Topo
  Imprimir  
 
Ir para:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines XHTML 1.0 Válido! CSS Válido!